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          Intermediate Training 
 
 
The material in this handout is taken directly from the Picasa Website.  It was 
decided to add all the information in one place so it could be viewed at one time.   
However, what is in this handout is a small part of all the help available on the 
Picasa website (http://picasa.google.com/support/)   
 
Also, not everyone has access to the internet.  Below is the outline for the Picasa 
Intermediate Training. 
 
 
 
 

A. Organize your Photos 
a. Create Albums 
b. Using the Picture Tray 
c. Searching for a Photo 
d. Adding and Removing Folders 
e. Adding and Moving Photos 
f. Captions 
g. Batch Editing 

 
B. Sharing 

a. Creating a CD 
b. Exporting to a Movie 
c. Images for the Desktop and/or Screen Savers 
d. Creating a Slide Show 
e. Ordering Prints 
f. Emailing Photos 
g. Creating and Exporting a Poster 
h. Collages 
i. Export your Photos 
j. Backing Up and Saving 

 
 
 
 
 
 
 

 
 
 
 
 



 2

Organizing your Photos 
 

 
 

What are folders and albums?  

Albums are virtual groupings of photos that only exist in Picasa. Like a playlist, 
you can create combinations of any photos in an album or use a single image in 
multiple albums, all without using extra space on your hard drive. Plus, if you 
delete photos in an album, or if you delete whole albums, your original photo files 
will be untouched. 
 
Picasa folders show you exactly how your photo files are arranged in the folders 
on your hard drive. This way, you can organize and manage photos on your hard 
drive using folders in Picasa. For example, moving a photo between folders in 
Picasa will result in the photo being moved between the same folders on your 
hard drive. Also, please note that deleting a photo from a folder will delete it from 
your hard drive. 
 
 
Creating Photo Albums 
 
First, select the photo or photos you wish to include in the Album. Once the 
desired photos appear in the Picasa Picture Tray, just click "File > New Album." 
You can also press the "Add To" button next to the Picture Tray and click the 
"New Album" option. Name the new album and enter any other information you 
wish. Click "OK" to create the new Album.  
 
 

What is the picture tray and where is it?  

The Photo Tray is located at the bottom left of the Picasa screen. It displays the 
photo or photos you currently have selected.  
 
The Hold button allows a viewed photo to stick in the Photo Tray. This function is 
useful when selecting photos from multiple Folders or Albums. 
 
The Clear button will remove your currently selection of photos from the Photo 
Tray. You will receive an "are you sure?" prompt before the Tray is cleared. 
 
The Add To button allows you to add the selected photo or photos to an existing 
or new Album.  
 

 

 



 3

How do I search for photos in Picasa?  

Picasa search can find any text associated with a photo. This includes the 
following: 
 
1. Filenames 
2. Captions 
3. Keywords 
4. Folder, Album, and Collection names 
5. Picture color 
6. Camera maker / settings 
7. Date ("November" or "2003") 
 
To search for any of these items, type them into the search box on the top-right 
hand side of the screen. To view all your photos again, clear your search by 
hitting the ESC key or clicking the button next to the text entry. 
 
Picasa can also search for your "starred" photos, for movies only, and it can filter 
the set of photos visible by date. Any search can be reset by closing the search 
panel.  
 
 

Why can't I find some of my photos in Picasa?  

If some of your photos are not appearing in Picasa, there are several steps you 
can take to retrieve them. 
 
1. Make sure Picasa is set to display small photos: 
 
Open Picasa > "View" > "Small Pictures" (a check mark will appear next to it). 
 
2. Make sure your "My Pictures", "My Documents" and your administrator folder 
are not marked as hidden folders. To check, right click the folder and select 
"properties". Your Folder should be marked as "Read Only" in the General tab. 
 
3. Next, in case you have hidden the photos, set Picasa to display "Hidden 
Pictures." This will make the hidden pictures viewable, although they will not be 
solid and clear. To display hidden pictures, please follow these steps: 
a. In Picasa, click "View." 
b. Click "Hidden Pictures" (a check mark will appear next to it). 
 
If you wish to restore a hidden picture, right-click on it and select "Unhide 
Picture." 
 
4. Check "Options" in Picasa to make sure the correct photo file types are 
selected: 
 
Open Picasa > "Tools" > "Options" > "File Types." 
 
If you are unsure what file types the missing photos are (JPG, TIFF, etc), just 
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check all of the File Types. Click "OK" when you are finished selecting file types. 
 
5. Check the Other Stuff collection to see if Picasa has filtered some photos. If 
you find the photos you are looking for here, just move them to the folder or 
folders you want them in 
 
6. Your next step is to check your settings in the Picasa Folder Manager: 
 
Click "Tools" > "Folder Manager." 
 
Set all locations and folders (Desktop, My Documents, C: , etc) to "Scan Always." 
The most common cause of lost images in Picasa is changing these settings. 
Also, check the "Recycle Bin" to see if the photos have been deleted. 
 
7. If you wish to rebuild the database in Picasa, hold down Ctrl-Shift-Alt, then 
open Picasa. Click "Yes" to the prompt. This is the last resort because you will 
lose all of your album organization.  
 
8. The next step is more drastic. You can uninstall then reinstall Picasa. During 
the uninstall process, you will be prompted to remove the Picasa database as 
well. Select "Yes" then, reinstall Picasa. After reinstalling Picasa, it will scan your 
hard drive and find all available photos. 
 
Please note that CMYK, unflattened, and transparent images will not be 
displayed (or displayed correctly) in Picasa.  
 
 

How do I add and/or Delete a folder to Picasa?  

To add a single folder to Picasa, do the following: 
 
1. Click "File." 
2. Click "Add Folder" to Picasa. 
3. Find the folder you wish to add by browsing through the "Picasa Folder 
Manager." 
4. When you find the folder, click it, then select either "Scan Always" or "Scan 
Once." 
5. Click "OK." 
 
All photos from the selected folder should now be available in Picasa.  
 
 

How do I move photos in Picasa?  

The easiest way to move photos between Folders and Albums is by dragging 
and dropping them. You can drag and drop multiple photos by holding the Ctrl 
key while clicking the desired photos. If you want to select all the photos in a 
Album or Folder, click on "All" underneath the title of the Folder or Album. 
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If you are selecting photos from multiple albums, make sure to click the "Hold" 
button before moving on to the next folder. 
 
If you are having difficulties scrolling through your groups of photos, try using the 
up and down arrows. It may also help to set the thumbnail size to smallest using 
the slider at the bottom right of Picasa.  
 

How do I move photos to a new folder?  

Picasa does allow you to move photos to a new folder. This function is only 
available when working with photos in Folders; it is not available from Albums. 
 
Select one or more photos from an album that you wish to move into a new 
folder. Right-click the photo (or any photo in the group you selected) and click 
"Move to New Folder." Enter a name and any other pertinent information for the 
new folder. Your photos will be moved instantly.  
 

How do I remove duplicate images?  

To remove duplicate pictures from your Folders or Albums, right click the image 
and select "Hide Picture."  
 

How do I delete an image?  

If you wish to permanently delete a photo from your computer using Picasa, just 
right-click on the photo and select "Delete from Disk." Click "Yes" to the "Are you 
sure?" prompt. This will send the photo file to the Windows recycle bin. 
 
If you want to remove a photo from Picasa or from a particular album, you can 
use the Hide feature. Just right-click the photo and select the "Hide picture" 
option. The photo should be instantly removed from Picasa. 
 

Captions 

You can add a caption to any photo while you’re in the “Edit Photo” screen. 
Underneath the individual photo, click on the text that says “Make a caption!” 
Type in your caption. You can show or hide a caption from the photo using the 
button on the left in the caption bar. You can delete a caption by clicking the 
trash can icon on the right.  

Captions in Picasa are stored in each photo’s EXIF data, so they stay with your 
photos. That means if you upload to a Picasa Web Album, your captions will also 
appear on the website. Captions are also searchable inside Picasa. 
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What is batch editing?  

Batch editing allows you to make edits to multiple photos at the same time: 
 
1. Select the photos you wish to apply edits to while holding down the Ctrl key. 
(Make sure that you select the "Hold" button in the "Picture Tray" when switching 
between albums.)  
2. Once you have all of your photos selected, click "Picture" > "Batch Edit".  
3. Select the editing feature that you wish to use. You should then see a window 
indicating that the thumbnails are being updated.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 



 7

Sharing 
 
 

How do I create a gift CD?  

When creating a gift CD/DVD of your photos, you have several options; you can 
include a slideshow or a copy of Picasa, or you can make prints from the CD by 
including only the photo files.  

To create a gift CD/DVD: 

1. Select the photos you'd like to copy to the CD/DVD.  
2. Click Gift CD.  

 

3. Enter a name or title for your CD/DVD.  
4. Optional: Add any additional items from the Gift CD menu (see below for 

more details).  
5. Insert a blank disk.  
6. Click Burn Disc.  

Gift CD Menu Options (please refer to the figures below): 

• To include an auto-running slideshow, select Include Slideshow.  
• To add more photos, click Add More.  

Note: If you add many photos, a message that Picasa is "Calculating" will 
appear in the blue bar above "Burn Disc." Wait until this message 
disappears before clicking "Burn Disc."  

• To resize the photos, click the Photo Size drop-down menu and choose a 
new size. If you don't want to resize your photos, choose Original Size.  

• To include a copy of Picasa, select Include Picasa.  

Tip: If you want to take the CD to a photo lab to make prints, just deselect 
Include Slideshow and Include Picasa.  
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Please note that it's not possible to copy audio files or include music on your CD 
or DVD. 

 

How do I use Picasa to make a movie?  

To make a movie from a selection of photos, follow the instructions below: 
 
1. Select the photos you'd like for your movie. You can also select multiple 
photos from different folders using the "Hold" button next to the Photo Tray. 
2. When you have the desired photos selected, select "Create." 
3. Select "Movie." 
4. Select "Delay between pictures" from the drop-down menu and a movie size.  
5. Click "OK." 
6. You'll see the option to compress your movie if you'd like to make the file size 
smaller. 
 
Your movie will now be saved in "My Pictures" and will also appear in Picasa. 
Please note that it's not possible to add music or audio to movies created in 
Picasa.  
 

How do I set my photos as Wallpaper?  

To set any photo as your Windows Desktop Wallpaper using Picasa, please do 
the following: 
 
1. Click the photo you wish to use as wallpaper. 
2. Click "Create" (next to File, Edit, View, etc.). 
3. Click "Set as Desktop..." 
4. Click "Yes" to the prompt 
 
Your photo will now be your Windows desktop background (wallpaper).  
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How can I set a photo as a Windows background?  

Follow these steps to set a photo as a Windows Background: 
 
1. Click on the selected picture. 
2. Go to Create > Set as Desktop Background from the drop-down menu. 
3. The selected picture is now your Windows background.  
 

How do I make a screensaver?  

Picasa includes its own screensaver which displays photos using various visual 
effects while your computer is inactive. You can configure the screensaver to 
show photos from various sources, including:  
 
- Picasa's special Screensaver and/or Starred Photos albums 
- Specific folders on your computer 
- Albums in your Picasa Web Albums account  
 
The screensaver must be activated before it will run. There are two ways to 
activate the screensaver from within Picasa: 
 
1. Go to "Tools" > "Configure Screensaver".  
2. Select photos you would like to display in the screensaver and go to "Create" > 
"Add to Screensaver".  
 
Both methods will launch the "Display Properties" control panel so that you may 
further configure the screensaver. On the "Screen Saver" tab, the Picasa 
Screensaver is selected for you automatically. Press the "Settings" button to 
launch the Picasa Screensaver's configuration dialog. In the dialog, you will see 
two tabs, one called "Photo Sources" and one called "Visual Presentation." 
 
Photo Sources 
------------- 
Use the checkboxes to turn each photo source on or off. Once a source is turned 
on, the "Configure" button for that source will become active. Press the 
"Configure..." button to see options specific to that photo source. 
 
Visual Presentation 
------------------- 
This tab allows you to choose the visual effect the screensaver uses to present 
your photos. Use the drop-down box to choose an effect. A preview of the effect 
will begin to animate. Some effects allow you to specify a time interval between 
transitions. In this case, a slider will appear which you can use to modify the time 
between transitions.  
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How can I create a custom slideshow?  

You can create a custom slideshow using photos from multiple Folders or 
Albums. 
 
You must first add all the desired photos to the Photo Tray. 
 
To select multiple photos that are in the same folder, hold the "Ctrl" key while 
clicking the photos.  
 
Before switching to a new folder to select more photos, click the "Hold" button 
next to the Photo Tray.  
 
Continue clicking photos and the Hold button until all the desired photos appear 
in the Photo Tray. In Picasa versions 2.5 and above you will click Add to > New 
Album. For versions before 2.5, click "Label" > "New Label". 
 
Enter the name of this group of photos and any other pertinent information. This 
group will appear as a new Album in Picasa. You can now run a slideshow using 
this new Album.  
 

Can I play music with my slideshow?  

Picasa allows you to set your slideshows to loop (repeat) infinitely and to be 
accompanied by music. Picasa can only play MP3 files; it cannot play from CDs 
or any other music format (iTunes AAC, etc.) 
 
To set your slideshow options: 
 
1. Choose "Options" from the Tools menu. The Options dialog appears. 
2. Click the "Slideshow" tab. 
3. Select "Loop slideshow" to repeat the slideshow until you stop it manually. 
4. Select "Play MP3" tracks during slideshow to play the tracks from the folder of 
MP3 files during slideshows. 
5. Click the Browse button to select a folder from which to play MP3 music during 
slideshows. The music files in this folder will play continuously-one after the 
other-until the slideshow stops. When the last MP3 file in the folder is played and 
the slideshow is still running, Picasa will loop to the first MP3 file in the folder and 
continue playing. 
6. Click "OK" to save your selections. 
 
Picasa uses Windows Media Player to play MP3s and video files. If you are 
unable to play MP3s with your slideshows, please make sure that you are 
running the most recent version of Windows Media Player. 
 
You can download the most recent version of Media Player from Microsoft here: 
 
http://www.microsoft.com/windows/windowsmedia/mp10/default.aspx  
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How do I order prints using Picasa?  

You can order prints from a variety of vendors by following these steps: 
 
1. Select the photos you'd like to print. Your selected photos will appear in the 
Picture Tray in the lower left corner. Hold the "Ctrl" key to select multiple pictures 
and press the "Hold" button to the right of the Picture Tray when ordering photos 
from multiple albums. 
2. Click the "Order Prints" button at the bottom of the screen. 
3. Choose the vendor that you wish to use from the list. 
4. Sign in using your username and password for that particular site. Note: this is 
not the same as your Picasa account. If you don't have an account with that 
vendor, click "Create an Account."  
5. Once you sign in, Picasa will transfer your selected photos to the print 
processor's site. 
6. Follow the instructions located on the site to complete your order. 
 
You can find a full list of available print vendors by clicking "Order Prints" at the 
bottom of the Picasa screen.  
 

How do I set Picasa to send email using my email program?  

You can set Picasa to send email using your email program. Please do the 
following: 
 
1. Open Picasa. 
2. Click "Tools" > "Options" > "Email." 
3. Under "Email Program," set Picasa to use your email program. 
4. Click "OK." 
 
You should now be able to send email using your email program.  
 

How do I create a poster in Picasa?  

You can create a poster by printing large photos on a regular printer. This will 
separate your photo into four quadrants and print each quadrant separately. After 
printing all four sheets, you can then tape or glue them together to create a 
poster. We've included detailed instructions below: 
 
1. Select the desired photo by clicking on it. 
2. Click "Create" at the top of the window and select "Make a Poster" from the 
drop-down menu. 
3. You can enlarge your poster by selecting a size from the "Poster size" menu. 
4. Select your paper size and check or uncheck "Overlap tiles." When enabled, 
this feature will cause the image on each sheet to slightly overlap, making it 
easier to line them up and attach them later. 
5. Click "OK." 
 
Picasa will then make a copy of your original photo, so your original photos 
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remain untouched. You'll find the four new poster photos in Picasa, ready for 
printing.  
 

How do I create a collage in Picasa?  

You can use Picasa to create one-of-a-kind photo collages. To create a Picasa 
collage, please follow the instructions below:  

1. Select the photos you’d like to include in your collage. Your selected 
photos will appear in the Photo Tray in the lower-left corner of the screen. 
Press the Ctrl key to select multiple pictures, and press the "Hold" button 
when adding photos from multiple albums or collections.  

 

2. Click "Collage." 
Note: If the "Collage" button is disabled, you will need to first select photos 
for your collage.  

 

3. Choose from the "Type" and "Options" drop-down menus to preview your 
collage.  
Tip: By clicking directly on the collage preview, you can change the order 
of your photos. To shift the layout of a Picture Pile collage, press the Shift 
key while clicking on the collage preview.  

4. Choose a folder from the “Location” drop-down menu. Your collage will be 
saved to this folder.  
Note: The photos Picasa uses in your collage are actually copies of your 
original photos. This way, your original photos remain untouched.  

5. When you're satisfied with your collage, click "Create"  
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You can see examples of different types of collages below: 

   

    

   

    

   

    

Picture Grid Contact Sheet Multi-Exposure 
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You can use your new collages on mugs, aprons, greeting cards, and more. For 
detailed instructions on ordering photo products, please see 
http://picasa.google.com/support/bin/answer.py?answer=19599 

 
How do I export in Picasa?  

You can use Picasa's "Export" feature to save copies of your edited photos. 
Unlike "Save," exporting allows you to choose a different location to export to, 
and allows you to select the image size and quality of the exported copy.  
 
1. Select the photos you want to export. Click "Hold" to select photos from 
different folders. 
2. Click "Export" at the bottom right of the screen. 
3. In the "Export to Folder" screen, you'll see the option to change the folder 
name and location of your exported photos, as well as image size and quality 
options.  
4. Click "OK." 
 
Your exported images will now be saved on your hard drive and be visible in 
Picasa. By default, the copied images will be in My Pictures\Picasa Exports on 
your computer. In Picasa, you can find the exported photos under "Exported 
Photos."  
 

How do I back up my photos to another drive?  

You can choose to run a Picasa backup to another drive instead of to a CD or 
DVD. 
 
1. If you are copying your backup to a removable drive, hook it up first. 
2. Select "Backup Pictures" from the Tools menu. 
3. Click "New Set." 
4. Label the New Backup set. 
5. Select "Disk to Disk Backup." 
6. Click "Choose." 
7. Select the Drive or Folder you wish to export the Backup too. 
8. Make sure all the Folders and/or Albums you wish to include in the Backup are 
selected. 
9. Click "Backup." 
 
Your backup will be copied to your drive of choice.  
 

 

 


